Ford Maverick Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Alright, this thing is making me feel stupid. I have Maverick XL with the 100A interior package, 4K tow, and copilot 360. For the life of me I cannot figure out how to turn on the android auto. I have a Pixel 3 XL running latest Android 11. I've tried the USB C-C cable that came with my pixel and went and bought a samsung 3.3 ft. USB A->C cable. Neither works.

Everything I've read online indicates I have Android Auto capability. The windows sticker that came with my truck indicates I have Android Auto capability. So...... what gives here?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Yep, I saw that in the owners manual too. Have been through I think allll the settings on my phone and on the truck. Went square by square. I'm about to head back to the dealership and big them until they figure it out.

Regarding the app on my phone- I have that too. Whenever I go in to connect vehicle it insists that no USB is connected. Despite charging just fine over the cord haha. I even enabled developer options so I could make sure it was defaulting to the file transfer thing instead of no data.
 

·
Registered
Joined
·
29 Posts
I catch Hell getting Android Auto to work in my girlfriend's car. Had to order a Google cable and connect before turning the car on. There is an issue in the settings and it resets itself every time it is connected.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #8 ·
So my wife has a pixel 3a and my son had THE SAME DAMN PHONE I DO. Both work great with the cable I purchased. So now I need to figure out what the heck is wrong with my phone. But either way, thanks for the posts! Turns out the problem is my specific phone.
 

·
Registered
XL, AWD, Area 51, Moon roof, tonneau cover Ordered 8/30
Joined
·
22 Posts
So my wife has a pixel 3a and my son had THE SAME DAMN PHONE I DO. Both work great with the cable I purchased. So now I need to figure out what the heck is wrong with my phone. But either way, thanks for the posts! Turns out the problem is my specific phone.
Also, make sure your bluetooth settings "allows nearby devices" to be visible
 
1 - 9 of 9 Posts
Top