Ford Maverick Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter · #1 ·
Looking at several videos I noticed that the Lariat displays the outside temperature on the 8" display. But on the XLT I only see two dashes -- where the temperature is displayed on the Lariat (See photo below). I searched the PDF manual for the Maverick and the word "Thermometer" is not in it at all. Can anyone tell me if the XLT displays the outside temperature?

1412
 

·
Registered
Joined
·
33 Posts
1413

An interior photo of the XL shows not one but two temperatures.
Since the air conditioner is set to 70 I assume that one temp is interior and the other exterior?
Not sure that production models will look like that.

I think most cars display outside temps somewhere.
It's a safety thing in wintertime so you know when roads may be icy.

The owners manual says (model unspecified):

WHAT IS THE INFORMATION BAR
The information bar displays information
related to the ambient air temperature,
odometer, compass, indicators and
warning lamps.
 

·
Registered
Joined
·
57 Posts
Discussion Starter · #5 ·
View attachment 1413
An interior photo of the XL shows not one but two temperatures.
Since the air conditioner is set to 70 I assume that one temp is interior and the other exterior?
Not sure that production models will look like that.

I think most cars display outside temps somewhere.
It's a safety thing in wintertime so you know when roads may be icy.

The owners manual says (model unspecified):

WHAT IS THE INFORMATION BAR
The information bar displays information
related to the ambient air temperature,
odometer, compass, indicators and
warning lamps.
I figured it showed the outside temperature. It's just every photo I saw of the XLT had two dashes -- where the temperature was shown displayed on the Lariat. I searched for the word "temperature" in the manual, and there were over 130 hits! I got tired of looking.

-Thanks
 

·
Registered
Joined
·
9 Posts
From what I remember, the two dashes usually either mean an AAT sensor malfunction or the battery has recently been disconnected and SYNC needs a reboot. I’d bet it was the second one when they took the pic 🤷‍♂️
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top